Solution: The testing framework could not be installed because the PHP cURL library is not available (Drupal 7 on WAMP-server, Windows 7)

On Windows 7, Drupal 7, WAMP server running PHP 5.4.3 apache 2.4.2:

If you get the message

on http://yourdrupal/update.php, even though you’ve enabled curl in php.ini in both the Apache- and the php-binfolder and through the wamp-trayicon thing, try the following:

  • Go to http://www.anindya.com/php-5-4-3-and-php-5-3-13-x64-64-bit-for-windows/
  • Under “Fixed curl extensions”, download the curl-dll that corresponds to your php-version. NOT the nts-one, the VC9-one.
  • Replace your php_curl.dll in the C:\wamp\bin\php\php5.4.3\ext folder (or wherever your WAMP is installed)
  • Restart WAMP-server
  • If still not working: try copying php_curl.dll into both folders c:\windows\system32 and c:\windows\SysWOW64 and restart WAMP again.
  • If still not working – good luck bro, sorry.

 

Source:

http://stackoverflow.com/a/10977022/430885

Join the conversation

  • 4smarkov - 4 years ago

    thank you. it helped.